Delays in Sending and Receiving Emails on Office 365
Incident Report for Speak Digital
Resolved
Microsoft have resolved this issue which was caused by a problem on their internal infrastructure. Any delayed emails should now have been delivered. If you still notice any problems please contact us in the usual way. Thanks very much
Posted Jul 06, 2022 - 12:28 UTC
Identified
Microsoft have notified us that some users may experience delays when sending or receiving email messages. We will monitor the situation and post an update here when we have more information.
Posted Jul 06, 2022 - 09:21 UTC
This incident affected: Microsoft Office 365.