Zen Internet - Routing Outage
Incident Report for Speak Digital
Resolved
The issue at Zen was resolved just before 2pm. Apologies for any inconvenience this may have caused.
Posted Apr 18, 2024 - 14:07 UTC
Identified
Our broadband provider Zen are experiencing a nationwide outage that is causing some customers to be unable to use the internet properly. Their network teams are aware of the issue and currently investigating this. Please watch here for an update.
Posted Apr 18, 2024 - 12:20 UTC
This incident affected: Broadband / Internet Connectivity.