Microsoft 365 Issues Affecting Outlook and Teams
Incident Report for Speak Digital
Resolved
Although the incident with Microsoft remains open we are seeing no further problems. If you are experiencing any issues please do raise a ticket in the usual fashion.
Posted Jan 25, 2023 - 14:21 UTC
Monitoring
Microsoft are still reporting this as an open incident but we have seen normal service restored across the board so let us know if you are still having issues with Microsoft 365.
Posted Jan 25, 2023 - 11:57 UTC
Identified
Microsoft have released an update. This issue is affecting the following services:

-Microsoft Teams
-Exchange Online
-Outlook
-SharePoint Online
-OneDrive for Business
-Microsoft Graph

They've identified a potential networking issue and are reviewing telemetry to determine the next troubleshooting steps.
Posted Jan 25, 2023 - 08:27 UTC
Investigating
Good morning. We have had reports that users are experiencing issues with slowness/crashing in Outlook and Teams. Microsoft have an active incident but have not yet confirmed the issue. We will update you when we know more.
Posted Jan 25, 2023 - 08:18 UTC
This incident affected: Microsoft Office 365.