Incoming Calls to Speak Digital not completing
Incident Report for Speak Digital
Resolved
Calls are now coming through as usual. Thanks for bearing with us.
Posted Nov 01, 2022 - 15:55 UTC
Identified
There is currently a fault causing problems reaching us on our main number 020 8970 7980. If you cannot get through please email heldpesk@speakdigital.co.uk and we will call you back. Thanks
Posted Nov 01, 2022 - 09:36 UTC
Investigating
Some clients have reported problems reaching us on our main number 020 8970 7980. If you cannot get through please email heldpesk@speakdigital.co.uk and we will call you back. Thanks
Posted Nov 01, 2022 - 09:14 UTC
This incident affected: VOIP Phone System.