Internet issues on Hosted Desktop
Incident Report for Speak Digital
Resolved
The DNS issue has now been resolved.
Posted Feb 12, 2024 - 17:13 UTC
Identified
We are aware of a problem with DNS on our hosted desktop platform that is preventing internet access outbound. We have located the issue and are working to resolve it very shortly.
Posted Feb 12, 2024 - 16:59 UTC
This incident affected: Citrix Hosted Desktops.