Users may not see shared mailboxes appearing in the Outlook desktop client
Incident Report for Speak Digital
Resolved
Microsoft resolved the issue earlier today and all missing mailboxes should now be visible. Thank you for your patience.
Posted Sep 12, 2023 - 15:46 UTC
Identified
Microsoft have notified us of an issue that is preventing shared mailboxes from appearing in Outlook. They are working to remediate it but in the meantime users can access shared mailboxes via https://outlook.office.com and selecting "Open Other Mailbox" from the top right menu.
Posted Sep 12, 2023 - 08:16 UTC
This incident affected: Microsoft Office 365.