Closed for Christmas / New Year
Incident Report for Speak Digital
Resolved
We are back and ready to help you in 2024!
Posted Jan 02, 2024 - 08:56 UTC
Monitoring
Our office is closed for the Christmas / New year break. We are not responding to helpdesk tickets.
If you have a contract with us and an emergency please call on the usual number.
Posted Dec 22, 2023 - 10:55 UTC