Difficulties reaching the helpdesk by Phone
Incident Report for Speak Digital
Resolved
Calls seem to be flowing as usual.
Posted Sep 05, 2022 - 12:22 UTC
Investigating
A few customers have reported they cannot get through to the support desk by phone. We are investigating but if you need assistance in the meantime please email helpdesk@speakdigital.co.uk and we will call you right back. Thanks.
Posted Sep 05, 2022 - 11:36 UTC
This incident affected: Other Notifications.