VOIP Phones Unregistered / Helpdesk Down
Incident Report for Speak Digital
Resolved
Services came back to normal very quickly. We will continue to monitor but please do open a ticket if you are having any issues. Thank you
Posted Mar 23, 2022 - 12:07 UTC
Investigating
We are seeing cases of phones temporarily unregistering. This is including our own helpdesk phones so if you can't reach us by phone please email helpdesk@speakdigital.co.uk. We are actively looking into this matter.
Posted Mar 23, 2022 - 11:59 UTC
This incident affected: VOIP Phone System.