Citrix outage
Incident Report for Speak Digital
Resolved
This problem has been resolved if you are still experiencing issues please close Citrix completely and connect again. If you are still having problems please let us know
Posted Jan 07, 2021 - 15:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 07, 2021 - 15:21 UTC
Identified
Our supplier has identified the issue and is working on a resolution now. we expect a maximum downtime of around 20 minutes. Apologies for this disruption
Posted Jan 07, 2021 - 15:13 UTC
This incident affected: Citrix Hosted Desktops.